Получите стоимость продвижения
Нажимая на кнопку «Отправить», я даю согласие на обработку своих персональных данных и соглашаюсь с политикой конфиденциальности.

Простые функции Excel для оптимизатора

SEO-специалист постоянно работает с данными – он их получает, преобразовывает, структурирует, сортирует, фильтрует. В этом деле очень помогает Excel. В этой статье расскажем про основные функции необходимые для оптимизатора.

ИСХОДНЫЙ ФАЙЛ (СКАЧАТЬ XLSX-ФАЙЛ)

Для работы с файлом, в котором собраны продвигаемые поисковые запросы, обычно предусматривают следующие колонки:

  • Ключевое слово
  • Продвигаемый URL
  • Релевантный URL
  • Частота (WS)
  • Позиция в Яндексе
  • Позиция в Google
скриншот_1

Сортировка по полю

Это можно сделать в несколько кликов, выделив всю таблицу и добавив фильтр. После этого можно будет сортировать по любому полю.

скриншот_2 скриншот_3

Выделение уникальных значений и/или дублей

Если нужно выявить дубли, чтобы найти уникальные ключевые запросы, следует воспользоваться функцией "условное форматирование". Для этого необходимо выделить зону, в которой будет осуществляться поиск дублей или уникальных значений, а затем задать условия функции.

скриншот_4 скриншот_5

Удаление повторов

Можно удалить дублирующиеся значение с помощью функции «Удаление дубликатов»

скриншот_6

Цветовое выделение значений

Чтобы выделить цветом определенные значения в заданном диапазоне, необходимо выделить ячейку, строку или столбец, а затем нажать на "условное форматирование". Далее можно дать программе задание – вариантов здесь несколько.

Например, нужно выделить позиции в ТОП 10

скриншот_7 скриншот_8

Например, нужно раскрасить все позиции градиентом, что в ТОПе зеленое, а что далеко за ТОПом - красное

скриншот_9 скриншот_10

Поиск запросов с заданным словом

Если нужно найти все ячейки, в которых есть нужное вам слово (к примеру, "интернет-магазин", "цена" или др.), делаем это через поиск CTRL+F.

скриншот_11

Нажимаем CTRL+A для выделения всех найденных ячеек и красим в какой-либо цвет

скриншот_12

Расчет значения по формуле

В Exсel предусмотрены расчеты значений по различным формулам. Самые часто используемые формулы:

=СУММЕСЛИ

Например, нам нужно узнать суммарный спрос всех запросов, которые ведут на страницу https://site.ru/katalog/derevyannyie-okna/

Тогда вводим формулу:

=СУММЕСЛИ(C2:C33;H2;D2:D33)

скриншот_13

=СУММ

Например, нужно узнать суммарный спрос всех запросов. Выделяем необходимый диапазон

=СУММ(D2:D33)

скриншот_14

=ВПР

Например, из другого листа необходимо подянуть новые позиции

Для этого можно воспользоваться формулой ВПР.

=ВПР(A2;Лист1!A:B;2;ЛОЖЬ)

А после растянуть значения

=СЧЁТЕСЛИ

скриншот_15

Например, нам нужно посчитать кол-во запросов, которые ведут на страницу

=СЧЁТЕСЛИ(C2:C33;H2)

скриншот_16

=СОВПАД

Например, нам нужно проверить совпадает ли релевонтный урл с продвигаемым

=СОВПАД(B2;C2)

скриншот_17

Если значение «Истина», то урлы сопрадают.

Фиксация ячейки в формуле для одной из переменных

Если требуется зафиксировать конкретную ячейку в формуле, то перед буквой и цифрой необходимо поставить $. Например, $F$5

Если требуется зафиксировать только указанную строку, то ставим $ только перед цифрой. Например, F$5

Если требуется зафиксировать только указанный столбец, то ставим $ только перед букой. Например, $F5

Данный фиксаторы обязательно нужно ставить если вы планируете растягивать формулы. Например, если вы растянете формулу:

=СУММЕСЛИ(C2:C33;H2;D2:D33)

Вниз, то получите некорректные значения, т.к. формула съедет на 1 стоку вниз:

скриншот_18

А если вы добавите $, то такой проблемы не будет:

=СУММЕСЛИ($C$2:$C$33;H3;$D$2:$D$33)

скриншот_19
Получить коммерческое
предложение
1
Какие виды услуг вас интересуют
ещё
2
Бюджет проекта
Укажите примерную сумму которую планируете потратить на разработку проекта
3
Оставьте ваши контакты и мы свяжемся с вами
Нажимая на кнопку «Отправить», я даю согласие на обработку своих персональных данных и соглашаюсь с политикой конфиденциальности.
Клиентский отдел и сервис контроля качества
с понедельника по пятницу с 10:00 до 19:00:
+7 (495) 308 08 19+7 (800) 555 97 91
бесплатно из регионов